Yarn 1.4.0 发布,Facebook 推出的 JavaScript 包管理器

Facebook 推出的 JavaScript 包管理器 Yarn 发布了 1.4.0 版本,该版本的主要更新是对 bug 进行修复,此外还新增了一些功能特性。


部分更新内容如下:


当新版本未在"yarn publish"上提供时,显示当前版本号


从 homebrew npm 使用 node-gyp


修复认证条件和注册表的逻辑


详细更新说明和下载地址请查看 GitHub 发布主页。


Yarn 是 Facebook 推出的 JavaScript 包管理器,旨在提供 npm 之外的另一种选择方案。Yarn 具有极佳的伸缩性,可以支持成千上万个直接或间接的包依赖。Yarn 的设计初衷是保证稳定性、弹性和高性能。


那么 Yarn 和 npm 有什么不同呢?两者最大的不同在于安装包的方式,Yarn 用到了 lockfiles 和确定性算法。Lockfile 会把安装的包版本进行锁定,保证了 node_modules 目录在不同设备上的安装结果是一致的,同时支持并行操作,大大加快安装进程。此外,Yarn 还声明同时兼容 npm 和 Bower,支持两个仓库混合使用,同时支持包的离线安装(只要你曾经安装过这个包)。


Yarn 1.0 的发布时间是 2017 年 9 月,可点此查看更新内容。

0 个评论

要回复文章请先登录注册